Edit product

$29.95

vFlyteAir Simulations Piper Twin Comanche PA30 for X-Plane 11


Now version 1.3!

Compatible with X-Plane 11.1x or newer, the Twin Comanche is Virtual Reality ready! New FMOD sounds, improved autopilot, save-state preferences, switches and menu sizes and positions. Now ships with the STMA AutoUpdate plugin so that your copy will stay up to date with the newest changes! Also includes many bug fixes.

Requirements: X-Plane 11.10 or newer, dedicated high-performance graphics card, multi-core processor computer. Virtual Reality requires Oculus Rift or HTC Vive and X-Plane 11.20vr1.

You've purchased this product

See it in your library

View in Library
Sorry, this item is not available in your location.
Sold out, please go back and pick another option.

0 ratings

Checkout

vFlyteAir Simulations Piper Twin Comanche PA30 for X-Plane 11

Enter your info to complete your purchase

Card

···· ···· ···· 4242
Test card

05/18

Card

Use a different card?

Card

pp paypal

or pay with

We do not keep any of your sensitive credit card information on file with us unless you ask us to after this purchase is complete.

or pay with

You'll be charged US$29.95.

Your purchase was successful!

We charged your card and sent you a receipt

    Gumroad Library

    Download from the App Store or text yourself a link to the app

    Thank you for purchasing from vFlyteAir.com. You will receive automatic email notices when we update your product!

    Good news! Since you already have a Gumroad account, it's also been added to your library.

    Powered by Gumroad